Phantom Inventory on Bin Location Report

I had a user incorrectly enter inventory and did not put it in a bin location so it got put in the Default bin location which I guess is a catch all location.
I deleted the transaction and recorded inventory so it shows correctly in the new location, the quantity is correct but it also still shows a line item for Default location with a Quantity of 0.

This was done for several items.

I also have another item that shows -1 in the quantity in the Default bin but there are not any inventory transactions associated with it so its not counting towards the total on the stock card, and not listed in stock history but it’s confusing for these items to show up on the reports.

Is there any way to remove the phantom inventory so it doesn’t show on the report?

Hey @djicode

So we have a table called product_availability that keeps track of the quantity on hand for all inventory items across all locations. It’s used when we need to return QoH for an entire location or multiple products / inventory items (i.e. reports, search results, etc).

The product availability table is supposed to be refreshed whenever a transaction is created, updated, or deleted. However, we had some issues with 0.8.15 (and possibly with 0.8.14) where sometimes the data in the table became stale due to the following issues:

  • a race condition (the process used to refresh the product availability table sometimes occurred before the transaction was flushed to the database)
  • an exception that occurred while trying to refresh product availability

Both of these issues have been fixed so I would recommend upgrading to 0.8.15-hotfix3 if you haven’t already.

In the meantime, you can trigger a product availability refresh manually by clicking on the Refresh Caches option on your user dropdown menu.

NOTE: The stock card page (above) for every product always shows the correct QoH (calculated from the product’s transactions at the given location). So you can always trust those quantities to be accurate.

Thanks so much for the reply! I’ll give that a whirl in the morning when I’m back in the office.

Awesome, all fixed now! Thanks for the help. I upgraded from hotfix 1 to 3 and refreshed the cache and everything looks good now!

I upped the memory and processor allotment as well on the ubuntu vm I’m running it on and it’s working really well now.

Good to hear.

Just out of curiosity how much memory / CPU are you using?