Context [/openboxes] startup failed due to previous errors

OS: Windows Server 2022
DB: MySQL
Memory: 8GB

catalina.2022-11-15.log: Nov 15, 2022 11:05:14 AM org.apache.catalina.startup.VersionLoggerListener log - Pastebin.com
tomcat7-stderr.2022-11-15.log: 2022-11-15 11:05:13 Apache Commons Daemon procrun stderr initialized.Nov 15, - Pastebin.com
tomcat7-stdout.2022-11-15.log: (in reply below)

I previously noticed errors along the lines of being out of memory, so I increased the initial and maximum memory pools to 3072MB (up from 128MB and 256MB, respectively).

Not sure what to try next…

tomcat7-stdout.2022-11-15.log: 2022-11-15 11:05:13 Apache Commons Daemon procrun stdout initialized.Using c - Pastebin.com

Looks like it’s an issue with permgen not heap.

Caused by: java.lang.OutOfMemoryError: PermGen space
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at net.sf.cglib.core.ReflectUtils.defineClass(ReflectUtils.java:384)
    at net.sf.cglib.core.AbstractClassGenerator.create(AbstractClassGenerator.java:219)
    at net.sf.cglib.proxy.Enhancer.createHelper(Enhancer.java:377)
    at net.sf.cglib.proxy.Enhancer.create(Enhancer.java:285)

To increase the perm size, edit the following line in tomcat.service

Environment='CATALINA_OPTS=-Xms1024m -Xmx1024m -XX:MaxPermSize=128m -server -XX:+UseParallelGC'

MaxPermSize is 64m by default. Increase it to 128m or 256m.

See documentation

Sorry. You’re using Windows, so you’ll need to edit MaxPermSize from the Windows Service UI.

https://stackoverflow.com/questions/52757958/increase-permgen-space-tomcat7-windows-service

This worked! I’m finally at the login screen.

New issue (not sure if a new thread needs to be created):
image

There are no results for reCAPTCHA anywhere on discuss.openboxes.com and docs.openboxes.com, so not sure what to do next…

That’s odd. reCAPTCHA is disabled by default. Did you copy all the config properties into openboxes-config.properties and/or openboxes-config.groovy?

What additional config properties are available? I only copied the database connection ones as outlined in Configuration - OpenBoxes.

Ok, that’s weird. Ignore my previous comment / question then.

Can you add this line to

openboxes.signup.recaptcha.enabled = false

to

file:C:\Windows\ServiceProfiles\LocalService/.grails/openboxes-config.groovy

It must go in openboxes-config.groovy and not openboxes-config.properties as boolean values aren’t handled properly in .properties files.

If that doesn’t work, then we can create a ticket and I’ll investigate further.

What version of OpenBoxes are you using?

I created a plain text file (.groovy extension, not .txt or anything else) called openboxes-config.groovy with that single line in it. Restarted Tomcat, waited a few minutes for everything to come back to life, and it’s still saying reCAPTCHA isn’t configured.

This is OpenBoxes 0.8.20.

Can you post the log files to pastebin again? I think the stdout and stderr should be enough.

I just had a chance to investigate the issue and it looks like it’s a bug. I’ll try to get a fix out for this in the next few days.

In the meantime you can create new users through the User Management feature.

Ah, there’s a default username and password. I’m in! Thanks.

Doh. I should have mentioned that. :cry:

No worries. I suppose it should be mentioned in the installation guide (Getting Started - OpenBoxes) rather than only in the developer guide (Getting Started - OpenBoxes), unless I missed it elsewhere.

1 Like

I’ve added tickets for the two issues

Awesome. The support here has been great.